Hope College CIT - Issue with the Titanium Server – Incident details

Issue with the Titanium Server

Resolved
Major outage
Started 6 days agoLasted about 2 hours

Affected

Third-Party Tools

Major outage from 2:45 PM to 5:12 PM

Titanium

Major outage from 2:45 PM to 5:12 PM

Updates
  • Resolved
    Resolved

    Titanium has been restored and is once again functional. Reach out to CIT with any questions or concerns.

  • Investigating
    Investigating

    We're looking into reports that the on-campus server called Titanium isn't working as expected. We'll update here when we know more.