Hope College CIT - Issues logging into Health Center Patient Portal – Incident details

Cloudflare → Cloudflare Sites and Services → Workers experiencing degraded performance

Issues logging into Health Center Patient Portal

Resolved
Major outage
Started about 2 months agoLasted about 21 hours

Affected

Third-Party Tools

Major outage from 8:43 PM to 5:57 PM

Health Center Patient Portal (Medicat)

Major outage from 8:43 PM to 5:57 PM

Updates
  • Resolved
    Resolved

    Health Center Portal Login has been fixed.

  • Investigating
    Investigating

    The Health Center is working with their vendor to resolve issues logging into the patient portal.