Hope College CIT - Terra Dotta Unavailable today – Incident details

Cloudflare → Cloudflare Sites and Services → Workers experiencing degraded performance

Terra Dotta Unavailable today

Resolved
Major outage
Started 2 months agoLasted about 23 hours

Affected

Third-Party Tools

Terra Dotta Study Abroad (travel.hope.edu)

Updates
  • Resolved
    Resolved

    travel.hope.edu is working again as expected. Sorry for the inconvenience. Please let the Help Desk know (cit@hope.edu or 616.395.7670) if you're still having issues.

  • Investigating
    Investigating

    We're looking into a critical issue with Terra Dotta. We'll update here when we know more.