Hope College CIT - PeopleAdmin (jobs.hope.edu) login error – Incident details

Campus WiFi experiencing degraded performance

PeopleAdmin (jobs.hope.edu) login error

Resolved
Major outage
Started 3 months agoLasted about 3 hours

Affected

Websites

Major outage from 1:24 PM to 4:15 PM

jobs.hope.edu

Major outage from 1:24 PM to 4:15 PM

Updates
  • Resolved
    Resolved
    This incident has been resolved.
  • Investigating
    Investigating

    We are currently investigating errors while trying to access or login to jobs.hope.edu