Hope College CIT - Authentication issue with plus.hope.edu – Incident details

B-lite experiencing degraded performance

Authentication issue with plus.hope.edu

Resolved
Operational
Started 27 days agoLasted about 1 hour

Affected

Banner
PLUS Login
Updates
  • Resolved
    Resolved
    This incident has been resolved.
  • Investigating
    Investigating

    CIT is investigating reports of authentication for plus.hope.edu is unavailable.