Student Housing Portal Outage

Resolved
Operational
Started 3 months ago Lasted about 1 hour

Affected

Third-Party Tools
Res Life Housing Portal (Adirondack THD)
Updates
  • Resolved
    Resolved

    The Housing Director (THD) software portal is accessible via all browsers again. Thank you for your patience while we worked on this issue!

  • Investigating
    Investigating

    The Housing Director (THD) software portal is experiencing unforeseen issues. We will update when we know more.