Hope College CIT - Logging into People Admin – Incident details

Logging into People Admin

Resolved
Major outage
Started 5 days agoLasted about 2 hours

Affected

Third-Party Tools

Major outage from 12:02 PM to 2:26 PM

PeopleAdmin (jobs.hope.edu)

Major outage from 12:02 PM to 2:26 PM

Updates
  • Resolved
    UTC
    Resolved

    Signing in with Google into PeopleAdmin is now working. All employees should be able to once again login to PeopleAdmin. Please reach out to CIT if you encounter any more issues.

  • Investigating
    UTC
    Investigating

    CIT has received reports that the authentication switch over with PeopleAdmin is experiencing issues. We are currently working with HR and the vendor to diagnose and work towards a fix.