Maintenance is scheduled on Banner Production for Wednesday, April 29, 5:30AM - 7:00AM
Completed
Scheduled for April 29, 2026 at 9:30 AM – 11:00 AM
Affects
Moodle
Under maintenance from 9:30 AM to 11:00 AM
Moodle Spaces
Under maintenance from 9:30 AM to 11:00 AM
Fall 2024 Moodle
Under maintenance from 9:30 AM to 11:00 AM
Spring 2024 Moodle
Under maintenance from 9:30 AM to 11:00 AM
Summer 2024 Moodle
Under maintenance from 9:30 AM to 11:00 AM
Spring 2025 Moodle
Under maintenance from 9:30 AM to 11:00 AM
Updates
Completed
April 29, 2026 at 11:00 AM
Completed
April 29, 2026 at 11:00 AM
Maintenance has completed successfully
In progress
April 29, 2026 at 9:30 AM
In progress
April 29, 2026 at 9:30 AM
Maintenance is now in progress
Planned
April 29, 2026 at 9:30 AM
Planned
April 29, 2026 at 9:30 AM
Maintenance is scheduled on Banner Production for Wednesday, April 29, 5:30AM-7:00AM to apply important Financial Aid updates and perform server maintenance. Systems will be down for approximately 90 minutes. Moodle, Degree Works and Argos may not be available during this down-time.
Note: The previously scheduled Maintenance window scheduled for Tuesday, April 28 at 5:30pm has been cancelled.