Issues for Hope Employees Logging into PeopleAdmin
Resolved
Partial outage
Started 13 days agoLasted about 4 hours
Affected
Third-Party Tools
Partial outage from 2:36 PM to 6:08 PM
PeopleAdmin (jobs.hope.edu)
Partial outage from 2:36 PM to 6:08 PM
Updates
Resolved
Resolved
After connecting with the vendor behind PeopleAdmin, we have resolved the issue. You are now once again able to access the system. Reach out to CIT if you encounter any issues with authenticating into the platform.
Investigating
Investigating
CIT has become aware that PeopleAdmin is having widespread issues with all of its clients for employees to login to the software. We are working with the vendor and update this page as they work to resolve it. The applicant login experience should not be affected.