Hope College CIT - CIT Ticketing System Outage – Incident details

Experiencing partially degraded performance

CIT Ticketing System Outage

Resolved
Major outage
Started 3 months agoLasted 18 minutes

Affected

Third-Party Tools

Major outage from 2:21 PM to 2:39 PM

CIT Ticketing System (helpdesk.hope.edu)

Major outage from 2:21 PM to 2:39 PM

Updates
  • Resolved
    Resolved

    The upstream issues have been resolved, and helpdesk.hope.edu is working once again. Thank you for your patience and let us know (cit@hope.edu or x7670) if you continue to have issues.

  • Investigating
    Investigating

    The system powering helpdesk.hope.edu is currently experiencing issues. We'll update here when we know more.

    https://status.happyfox.com/