Mitel/Phone System Upgrade
Scheduled for February 16, 2026 at 11:00 AM – 12:58 PM
Affects
Hope Infrastructure
Under maintenance from 11:00 AM to 12:00 AM
Campus Phones
Under maintenance from 11:00 AM to 12:00 AM
In progress
February 16, 2026 at 1:01 PMIn progress
February 16, 2026 at 1:01 PMMaintenance is now in progress.
Completed
February 16, 2026 at 12:58 PMCompleted
February 16, 2026 at 12:58 PMMaintenance will be extended until 10am.
In progress
February 16, 2026 at 11:00 AMIn progress
February 16, 2026 at 11:00 AMMaintenance is now in progress
Planned
February 16, 2026 at 11:00 AMPlanned
February 16, 2026 at 11:00 AMWe are planning for a scheduled maintenance during that time. Calling will be disrupted during this time.