Hope College CIT - Power Outage in Several Campus Buildings – Incident details

Cloudflare → Cloudflare Sites and Services → Workers experiencing degraded performance

Power Outage in Several Campus Buildings

Resolved
Partial outage 30 %
Started 2 months agoLasted 17 minutes

Affected

Hope Infrastructure

Partial outage from 1:54 PM to 2:11 PM

Campus WiFi

Partial outage from 1:54 PM to 2:11 PM

Campus Ethernet

Partial outage from 1:54 PM to 2:11 PM

Campus Phones

Partial outage from 1:54 PM to 2:11 PM

Campus Printers

Partial outage from 1:54 PM to 2:11 PM

Updates
  • Resolved
    Resolved

    Power has been restored. If you experience issues connecting to internet please reboot your computer.

  • Investigating
    Investigating

    College East, Gilmore, Physical Plant, Dow, and possibly other buildings just experienced a power outage. CIT is evaluating internet connectivity and equipment health after power was restored and will update here when we know more.