Hope College CIT - Issues with Google services – Incident details

Campus WiFi experiencing degraded performance

Issues with Google services

Resolved
Degraded performance
Started 3 months agoLasted about 16 hours

Affected

1Hope

Gmail

Google Chat

Google Drive

Google Docs

Google Calendar

Updates
  • Resolved
    Resolved

    Google resolved the issues with their services at approximately 6:00pm on Thursday evening.

  • Identified
    Identified

    Google Cloud is experiencing issues, which appear to be affecting various online services provided by Google, including our Hope email, Meet, Drive, search, etc, and also logging into services that use Google login such as Moodle.